import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/(?:(?:(?:www\\.)?youtu(?:(?:be\\.(?:com|nl|it|co\\.nz|com\\.br|de|es|ru))|(?:be-nocookie\\.com))\\/(?:(?:watch\\?v=)|(?:v\\/)|(?:embed\\/)))|(?:youtu\\.be\\/))(?<video_id>[a-zA-Z0-9\\-_]{11})(?:[a-zA-Z0-9\\-_\\?=&%\\.]+)?$";
final String string = "https://www.youtube.com/watch?v=Cf_4WmACpws\n"
+ "https://www.youtube.com/watch?v=oXXiJx7kaeE\n"
+ "https://youtu.be/Cf_4WmACpws?t=6879\n"
+ "https://www.youtube.com/watch?v=xYXV-SysdLw\n"
+ "https://www.youtube.nl/watch?v=xYXV-SysdLw\n"
+ "https://youtu.be/xYXV-SysdLw\n"
+ "https://www.youtube.com/channel/UClgRkhTL3_hImCAmdLfDE4g\n"
+ "https://www.youtube.com/feed/trending\n"
+ "https://youtu.be/YV-5SqpjBII&derp=%3Dhttps.comsfsdf\n"
+ "https://www.youtube.com/watch?v=6E3MMKzBn1g\n"
+ "https://www.youtube.com/feed/history\n"
+ "http://www.youtube.com/playlist?list=WL\n"
+ "https://www.youtube.com/watch?v=0f1cRNmQHVE\n"
+ "https://www.youtube.com/playlist?list=PLK8KId9LS-dRgDGDNLgMqBRXlwbUAuF0s\n"
+ "https://www.youtube.com/channel/UCFbNIlppjAuEX4znoulh0Cw\n"
+ "https://www.youtube.com/embed/M7lc1UVf-VE\n"
+ "http://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
+ "https://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
+ "http://www.youtube.com/watch?v=-wtIMTCHWuI\n"
+ "http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
+ "http://youtu.be/-wtIMTCHWuI\n"
+ "http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
+ "http://s.ytimg.com/yt/favicon-wtIMTCHWuI.ico\n"
+ "http://i2.ytimg.com/vi/-wtIMTCHWuI/hqdefault.jpg\n"
+ "https://www.youtube-nocookie.com/watch?v=Cf_4WmACpws\n"
+ "https://www.youtube.com/watch?v=inu0xeteuxg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}