const regex = /^https?:\/\/(?:(?:(?:www\.)?youtu(?:(?:be\.(?:com|nl|it|co\.nz|com\.br|de|es|ru))|(?:be-nocookie\.com))\/(?:(?:watch\?v=)|(?:v\/)|(?:embed\/)))|(?:youtu\.be\/))(?<video_id>[a-zA-Z0-9\-_]{11})(?:[a-zA-Z0-9\-_\?=&%\.]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/(?:(?:(?:www\\.)?youtu(?:(?:be\\.(?:com|nl|it|co\\.nz|com\\.br|de|es|ru))|(?:be-nocookie\\.com))\\\/(?:(?:watch\\?v=)|(?:v\\\/)|(?:embed\\\/)))|(?:youtu\\.be\\\/))(?<video_id>[a-zA-Z0-9\\-_]{11})(?:[a-zA-Z0-9\\-_\\?=&%\\.]+)?$', 'gm')
const str = `https://www.youtube.com/watch?v=Cf_4WmACpws
https://www.youtube.com/watch?v=oXXiJx7kaeE
https://youtu.be/Cf_4WmACpws?t=6879
https://www.youtube.com/watch?v=xYXV-SysdLw
https://www.youtube.nl/watch?v=xYXV-SysdLw
https://youtu.be/xYXV-SysdLw
https://www.youtube.com/channel/UClgRkhTL3_hImCAmdLfDE4g
https://www.youtube.com/feed/trending
https://youtu.be/YV-5SqpjBII&derp=%3Dhttps.comsfsdf
https://www.youtube.com/watch?v=6E3MMKzBn1g
https://www.youtube.com/feed/history
http://www.youtube.com/playlist?list=WL
https://www.youtube.com/watch?v=0f1cRNmQHVE
https://www.youtube.com/playlist?list=PLK8KId9LS-dRgDGDNLgMqBRXlwbUAuF0s
https://www.youtube.com/channel/UCFbNIlppjAuEX4znoulh0Cw
https://www.youtube.com/embed/M7lc1UVf-VE
http://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare
https://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail
http://www.youtube.com/watch?v=-wtIMTCHWuI
http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1
http://youtu.be/-wtIMTCHWuI
http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json
http://s.ytimg.com/yt/favicon-wtIMTCHWuI.ico
http://i2.ytimg.com/vi/-wtIMTCHWuI/hqdefault.jpg
https://www.youtube-nocookie.com/watch?v=Cf_4WmACpws
https://www.youtube.com/watch?v=inu0xeteuxg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}