use strict;
my $str = '{"json":[
{ "text":"Changed by 5" },
{ "text":"Changed by 345" },
{ "text":"Changed by 32" }
]}';
my $regex = qr/(\sby [0-9]+)/mp;
my $subst = '$1, done';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";