// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\sby [0-9]+)").unwrap();
let string = "{\"json\":[
{ \"text\":\"Changed by 5\" },
{ \"text\":\"Changed by 345\" },
{ \"text\":\"Changed by 32\" }
]}";
let substitution = "$1, done";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}