$re = '/(\sby [0-9]+)/m';
$str = '{"json":[
{ "text":"Changed by 5" },
{ "text":"Changed by 345" },
{ "text":"Changed by 32" }
]}';
$subst = "$1, done";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;