using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[\s+\w+\s+(?P<timestamp>\w+\s+\d+\s+\d+:\d+:\d+\s+\w+\s+\d+)\s+\]";
string input = @"[ Wed Jan 8 11:30:06 UTC 2020 ] INF: Tunnel front and end both server.version == local.version, no rotation needed
[ Wed Jan 8 11:30:00 UTC 2020 ] INF: Ssh to tunnelEnd is connected with pid: 86230
[ Wed Jan 8 11:29:55 UTC 2020 ] INF: going to sleep for:[5] Seconds";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}