// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[\s+\w+\s+(?P<timestamp>\w+\s+\d+\s+\d+:\d+:\d+\s+\w+\s+\d+)\s+\]").unwrap();
let string = "[ Wed Jan 8 11:30:06 UTC 2020 ] INF: Tunnel front and end both server.version == local.version, no rotation needed
[ Wed Jan 8 11:30:00 UTC 2020 ] INF: Ssh to tunnelEnd is connected with pid: 86230
[ Wed Jan 8 11:29:55 UTC 2020 ] INF: going to sleep for:[5] Seconds";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}