#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?i)(?:PID[#\s:]?|Patient ID[#\s:]?|Patient number ID[#\s:]?)\s*\d{7}\b"
Local $sString = "“PID 1234567”" & @CRLF & _
"" & @CRLF & _
"PID 1448017" & @CRLF & _
"" & @CRLF & _
"PID#5324081" & @CRLF & _
"" & @CRLF & _
"PID: 5269879 and 5270108" & @CRLF & _
"" & @CRLF & _
"PID 2087695" & @CRLF & _
"" & @CRLF & _
"PID 2097826"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")