import Foundation
let pattern = ##"\b(?i)(?:PID[#\s:]?|Patient ID[#\s:]?|Patient number ID[#\s:]?)\s*\d{7}\b"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
“PID 1234567”
PID 1448017
PID#5324081
PID: 5269879 and 5270108
PID 2087695
PID 2097826
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)