$re = '/\b(?i)(?:PID[#\s:]?|Patient ID[#\s:]?|Patient number ID[#\s:]?)\s*\d{7}\b/m';
$str = '“PID 1234567”
PID 1448017
PID#5324081
PID: 5269879 and 5270108
PID 2087695
PID 2097826';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);