package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][A-z]+ [a-z]+$`)
var str = `Homo sapiens
Homo Sapiens
HomoSapiens
Homo sapien2
homo sapien`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}