$re = '/^[A-Z][A-z]+ [a-z]+$/m';
$str = 'Homo sapiens
Homo Sapiens
HomoSapiens
Homo sapien2
homo sapien';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);