re = /^[A-Z][A-z]+ [a-z]+$/m
str = 'Homo sapiens
Homo Sapiens
HomoSapiens
Homo sapien2
homo sapien'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end