#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(@(typescript-)?eslint\/.*|eslint($|(?!.*next).*))"
Local $sString = "eslint" & @CRLF & _
"@eslint/js" & @CRLF & _
"eslint-config-prettier" & @CRLF & _
"eslint-plugin-next" & @CRLF & _
"eslint-plugin-import" & @CRLF & _
"eslint-config-foxkit" & @CRLF & _
"@typescript-eslint/parser" & @CRLF & _
"@typescript-eslint/eslint-plugin"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")