using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(@(typescript-)?eslint\/.*|eslint($|(?!.*next).*))";
string input = @"eslint
@eslint/js
eslint-config-prettier
eslint-plugin-next
eslint-plugin-import
eslint-config-foxkit
@typescript-eslint/parser
@typescript-eslint/eslint-plugin";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}