re = /(https?:\/\/.*\.(?:png|jpg)\?w=[0-9]+&crop=[0-9])/m
str = 'https://spy.com/wp-content/uploads/2022/01/Roborock-S6-Pure-Featured.jpg?w=232&crop=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end