// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:\/\/.*\.(?:png|jpg)\?w=[0-9]+&crop=[0-9])").unwrap();
let string = "https://spy.com/wp-content/uploads/2022/01/Roborock-S6-Pure-Featured.jpg?w=232&crop=1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}