package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[a-z][a-z0-9._]+[a-z0-9]+$)`)
var str = `username123
USername12
user 12
user-1234name$
user.name.
.username12
1username
username4444
user123user
user.name
user_name
user asdsad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}