use strict;
my $str = 'username123
USername12
user 12
user-1234name$
user.name.
.username12
1username
username4444
user123user
user.name
user_name
user asdsad';
my $regex = qr/(^[a-z][a-z0-9._]+[a-z0-9]+$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}