// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[a-z][a-z0-9._]+[a-z0-9]+$)").unwrap();
let string = "username123
USername12
user 12
user-1234name$
user.name.
.username12
1username
username4444
user123user
user.name
user_name
user asdsad";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}