const regex = new RegExp('(?<!\\\\)\\[([^][]+)]', 'gm')
const str = `[#5C9269]\\[Go to [size=120%]1[/size] now][/color] \\[don't match this] \\\\[match this]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}