re = /(?<!\\)\[([^][]+)]/m
str = '[#5C9269]\\[Go to [size=120%]1[/size] now][/color] \\[don\'t match this] \\\\[match this]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end