$re = '/(?<!\\\\)\[([^][]+)]/m';
$str = '[#5C9269]\\[Go to [size=120%]1[/size] now][/color] \\[don\'t match this] \\\\[match this]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);