#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<li class="cat-item cat-item-([^"]*)"><a href="([^"]*)">([^<]*)</a>([^<]*)</li>"
Local $sString = " <li class="cat-item cat-item-634"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/andersen-moormann-und-selb/">Andersen, Moormann und Selb</a>" & @CRLF & _
"</li>" & @CRLF & _
" <li class="cat-item cat-item-434"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/ballauf-und-schenk/">Ballauf und Schenk</a>" & @CRLF & _
"</li>" & @CRLF & _
" <li class="cat-item cat-item-48"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/batic-und-leitmayr/">Batic und Leitmayr</a>" & @CRLF & _
"</li>" & @CRLF & _
" <li class="cat-item cat-item-613"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/berg-und-tobler/">Berg und Tobler</a>" & @CRLF & _
"</li>" & @CRLF & _
" <li class="cat-item cat-item-555"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/berlinger/">Berlinger</a>" & @CRLF & _
"</li>" & @CRLF & _
" <li class="cat-item cat-item-619"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/borowski-und-sahin/">Borowski und Sahin</a>" & @CRLF & _
"</li>" & @CRLF & _
" <li class="cat-item cat-item-491"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/brix-und-janneke/">Brix und Janneke</a>" & @CRLF & _
"</li>" & @CRLF & _
" <li class="cat-item cat-item-474"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/dorn-und-lessing/">Dorn und Lessing</a>" & @CRLF & _
"</li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")