import Foundation
let pattern = #"<li class="cat-item cat-item-([^"]*)"><a href="([^"]*)">([^<]*)</a>([^<]*)</li>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<li class="cat-item cat-item-634"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/andersen-moormann-und-selb/">Andersen, Moormann und Selb</a>
</li>
<li class="cat-item cat-item-434"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/ballauf-und-schenk/">Ballauf und Schenk</a>
</li>
<li class="cat-item cat-item-48"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/batic-und-leitmayr/">Batic und Leitmayr</a>
</li>
<li class="cat-item cat-item-613"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/berg-und-tobler/">Berg und Tobler</a>
</li>
<li class="cat-item cat-item-555"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/berlinger/">Berlinger</a>
</li>
<li class="cat-item cat-item-619"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/borowski-und-sahin/">Borowski und Sahin</a>
</li>
<li class="cat-item cat-item-491"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/brix-und-janneke/">Brix und Janneke</a>
</li>
<li class="cat-item cat-item-474"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/dorn-und-lessing/">Dorn und Lessing</a>
</li>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)