package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<li class="cat-item cat-item-([^"]*)"><a href="([^"]*)">([^<]*)</a>([^<]*)</li>`)
var str = ` <li class="cat-item cat-item-634"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/andersen-moormann-und-selb/">Andersen, Moormann und Selb</a>
</li>
<li class="cat-item cat-item-434"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/ballauf-und-schenk/">Ballauf und Schenk</a>
</li>
<li class="cat-item cat-item-48"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/batic-und-leitmayr/">Batic und Leitmayr</a>
</li>
<li class="cat-item cat-item-613"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/berg-und-tobler/">Berg und Tobler</a>
</li>
<li class="cat-item cat-item-555"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/berlinger/">Berlinger</a>
</li>
<li class="cat-item cat-item-619"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/borowski-und-sahin/">Borowski und Sahin</a>
</li>
<li class="cat-item cat-item-491"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/brix-und-janneke/">Brix und Janneke</a>
</li>
<li class="cat-item cat-item-474"><a href="https://irgendwas.de/category/kommissare/kommissare-im-dienst/dorn-und-lessing/">Dorn und Lessing</a>
</li>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}