package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+\)`)
var str = `Programming is productive, (achieving a lot, and getting good results), it is often 1) demanding and 2) costly.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}