$re = '/\b\d+\)/m';
$str = 'Programming is productive, (achieving a lot, and getting good results), it is often 1) demanding and 2) costly.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);