re = /\b\d+\)/m
str = 'Programming is productive, (achieving a lot, and getting good results), it is often 1) demanding and 2) costly.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end