# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\w_\.]+)=([\-\w_\.]+);/\1=\2\n\1,F=0\n\1,1=0\n\1,2=0\n\1,3=0/gm;t' <<< "g_MA1=17;
g_MA2=20;
ExtTimeWindowStart=7;
ExtTimeWindowDuration=14;
ExtDayNotToTrade=6;
g_FilterState=0;
g_MAType=3;
g_use_MA_Factor=0;
g_MA_LB_Factor=2;
g_activateMA3=0;
g_MA3=80;
g_activateBBKC=0;
g_BBKCHighVolatility=0;
g_BBKC=10;
g_BBKCThreshold=0.75;
g_BBKCBarsLength=1;
g_activateSNR=1;
g_SNRCycle=0;
g_SNRPeriod=25;
g_SNRLevel=-15;
g_SNRBarsLength=1;
g_activateTI=1;
g_TI_LB=20;
g_MA1_Weight=3;
g_MA2_Weight=2;
g_MA3_Weight=1;
g_MA_TypeTI=3;
g_IsNormalized=1;
g_UpperThreshold=30;
g_LowerThreshold=-30;
g_orderType=0;
g_inversionSwitch=1;
g_barsNumber=3;
g_averageFactor=0;
g_DayLength=1;
g_activateOpposite=1;
g_activateDayTrade=0;
g_activateTradeDuration=0;
g_tradeDurationBars=10;
ExtSlPercent=0.25;"