#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\w_\.]+)=([\-\w_\.]+);"
Local $sString = "g_MA1=17;" & @CRLF & _
"g_MA2=20;" & @CRLF & _
"ExtTimeWindowStart=7;" & @CRLF & _
"ExtTimeWindowDuration=14;" & @CRLF & _
"ExtDayNotToTrade=6;" & @CRLF & _
"g_FilterState=0;" & @CRLF & _
"g_MAType=3;" & @CRLF & _
"g_use_MA_Factor=0;" & @CRLF & _
"g_MA_LB_Factor=2;" & @CRLF & _
"g_activateMA3=0;" & @CRLF & _
"g_MA3=80;" & @CRLF & _
"g_activateBBKC=0;" & @CRLF & _
"g_BBKCHighVolatility=0;" & @CRLF & _
"g_BBKC=10;" & @CRLF & _
"g_BBKCThreshold=0.75;" & @CRLF & _
"g_BBKCBarsLength=1;" & @CRLF & _
"g_activateSNR=1;" & @CRLF & _
"g_SNRCycle=0;" & @CRLF & _
"g_SNRPeriod=25;" & @CRLF & _
"g_SNRLevel=-15;" & @CRLF & _
"g_SNRBarsLength=1;" & @CRLF & _
"g_activateTI=1;" & @CRLF & _
"g_TI_LB=20;" & @CRLF & _
"g_MA1_Weight=3;" & @CRLF & _
"g_MA2_Weight=2;" & @CRLF & _
"g_MA3_Weight=1;" & @CRLF & _
"g_MA_TypeTI=3;" & @CRLF & _
"g_IsNormalized=1;" & @CRLF & _
"g_UpperThreshold=30;" & @CRLF & _
"g_LowerThreshold=-30;" & @CRLF & _
"g_orderType=0;" & @CRLF & _
"g_inversionSwitch=1;" & @CRLF & _
"g_barsNumber=3;" & @CRLF & _
"g_averageFactor=0;" & @CRLF & _
"g_DayLength=1;" & @CRLF & _
"g_activateOpposite=1;" & @CRLF & _
"g_activateDayTrade=0;" & @CRLF & _
"g_activateTradeDuration=0;" & @CRLF & _
"g_tradeDurationBars=10;" & @CRLF & _
"ExtSlPercent=0.25;"
Local $sSubst = "\1=\2\n\1,F=0\n\1,1=0\n\1,2=0\n\1,3=0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)