import re
regex = re.compile(r"([\w_\.]+)=([\-\w_\.]+);", flags=re.MULTILINE)
test_str = ("g_MA1=17;\n"
"g_MA2=20;\n"
"ExtTimeWindowStart=7;\n"
"ExtTimeWindowDuration=14;\n"
"ExtDayNotToTrade=6;\n"
"g_FilterState=0;\n"
"g_MAType=3;\n"
"g_use_MA_Factor=0;\n"
"g_MA_LB_Factor=2;\n"
"g_activateMA3=0;\n"
"g_MA3=80;\n"
"g_activateBBKC=0;\n"
"g_BBKCHighVolatility=0;\n"
"g_BBKC=10;\n"
"g_BBKCThreshold=0.75;\n"
"g_BBKCBarsLength=1;\n"
"g_activateSNR=1;\n"
"g_SNRCycle=0;\n"
"g_SNRPeriod=25;\n"
"g_SNRLevel=-15;\n"
"g_SNRBarsLength=1;\n"
"g_activateTI=1;\n"
"g_TI_LB=20;\n"
"g_MA1_Weight=3;\n"
"g_MA2_Weight=2;\n"
"g_MA3_Weight=1;\n"
"g_MA_TypeTI=3;\n"
"g_IsNormalized=1;\n"
"g_UpperThreshold=30;\n"
"g_LowerThreshold=-30;\n"
"g_orderType=0;\n"
"g_inversionSwitch=1;\n"
"g_barsNumber=3;\n"
"g_averageFactor=0;\n"
"g_DayLength=1;\n"
"g_activateOpposite=1;\n"
"g_activateDayTrade=0;\n"
"g_activateTradeDuration=0;\n"
"g_tradeDurationBars=10;\n"
"ExtSlPercent=0.25;")
subst = "\\1=\\2\\n\\1,F=0\\n\\1,1=0\\n\\1,2=0\\n\\1,3=0"
result = regex.sub(subst, test_str)
if result:
print(result)