using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"window\.location\.href\s*=\s*\""([^\""]+)\""";
string input = @"<html><meta charset=""utf-8"" /><title>检测中</title><div>跳转中</div></html>
<script> window.location.href =""/post/26784.html?btwaf=17282404""; </script>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}