re = /window\.location\.href\s*=\s*\"([^\"]+)\"/m
str = '<html><meta charset="utf-8" /><title>检测中</title><div>跳转中</div></html>
<script> window.location.href ="/post/26784.html?btwaf=17282404"; </script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end