import re
regex = re.compile(r"window\.location\.href\s*=\s*\"([^\"]+)\"", flags=re.MULTILINE)
test_str = ("<html><meta charset=\"utf-8\" /><title>检测中</title><div>跳转中</div></html>\n"
"<script> window.location.href =\"/post/26784.html?btwaf=17282404\"; </script>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")