# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{5})(\d+)/$1000/gm;t' <<< "11516798
11516000
98700000000"