re = /(\d{5})(\d+)/m
str = '11516798
11516000
98700000000'
subst = '$1000'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result