package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{5})(\d+)`)
var str = `11516798
11516000
98700000000`
var substitution = "$1000"
fmt.Println(re.ReplaceAllString(str, substitution))
}