// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)var [Aa-z0-9]{64}=[0-9]+").unwrap();
let string = "var a68d927e52e91be7d0491dc2b9d078a5e41fb6e8fdb26e1c969557e041eb1549=151";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}