import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}\\.\\d{3} \\+\\d{2}:\\d{2} \\[.*?\\] .{1,})";
final String string = "2023-12-10 00:50:50.789 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')\n"
+ "2023-12-10 00:50:50.883 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')\n"
+ "2023-12-10 00:52:38.701 +00:00 [ERR] An unhandled exception has occurred while executing the request.\n"
+ "System.InvalidOperationException: Unable to resolve service for type 'Swashbuckle.AspNetCore.Swagger.ISwaggerProvider' while attempting to Invoke middleware 'Swashbuckle.AspNetCore.Swagger.SwaggerMiddleware'.\n"
+ " at lambda_method1(Closure, Object, HttpContext, IServiceProvider)\n"
+ " at Microsoft.AspNetCore.Authorization.AuthorizationMiddleware.Invoke(HttpContext context)\n"
+ " at Microsoft.AspNetCore.Authentication.AuthenticationMiddleware.Invoke(HttpContext context)\n"
+ " at Microsoft.AspNetCore.Diagnostics.DeveloperExceptionPageMiddlewareImpl.Invoke(HttpContext context)\n"
+ "2023-12-10 00:55:11.363 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')\n"
+ "2023-12-10 00:55:11.453 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')\n"
+ "2023-12-10 00:55:30.194 +00:00 [ERR] An unhandled exception has occurred while executing the request.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}