const regex = new RegExp('(\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}\\.\\d{3} \\+\\d{2}:\\d{2} \\[.*?\\] .{1,})', 'gm')
const str = `2023-12-10 00:50:50.789 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')
2023-12-10 00:50:50.883 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')
2023-12-10 00:52:38.701 +00:00 [ERR] An unhandled exception has occurred while executing the request.
System.InvalidOperationException: Unable to resolve service for type 'Swashbuckle.AspNetCore.Swagger.ISwaggerProvider' while attempting to Invoke middleware 'Swashbuckle.AspNetCore.Swagger.SwaggerMiddleware'.
at lambda_method1(Closure, Object, HttpContext, IServiceProvider)
at Microsoft.AspNetCore.Authorization.AuthorizationMiddleware.Invoke(HttpContext context)
at Microsoft.AspNetCore.Authentication.AuthenticationMiddleware.Invoke(HttpContext context)
at Microsoft.AspNetCore.Diagnostics.DeveloperExceptionPageMiddlewareImpl.Invoke(HttpContext context)
2023-12-10 00:55:11.363 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')
2023-12-10 00:55:11.453 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')
2023-12-10 00:55:30.194 +00:00 [ERR] An unhandled exception has occurred while executing the request.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}