import re
regex = re.compile(r"(\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d{3} \+\d{2}:\d{2} \[.*?\] .{1,})", flags=re.MULTILINE)
test_str = ("2023-12-10 00:50:50.789 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')\n"
"2023-12-10 00:50:50.883 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')\n"
"2023-12-10 00:52:38.701 +00:00 [ERR] An unhandled exception has occurred while executing the request.\n"
"System.InvalidOperationException: Unable to resolve service for type 'Swashbuckle.AspNetCore.Swagger.ISwaggerProvider' while attempting to Invoke middleware 'Swashbuckle.AspNetCore.Swagger.SwaggerMiddleware'.\n"
" at lambda_method1(Closure, Object, HttpContext, IServiceProvider)\n"
" at Microsoft.AspNetCore.Authorization.AuthorizationMiddleware.Invoke(HttpContext context)\n"
" at Microsoft.AspNetCore.Authentication.AuthenticationMiddleware.Invoke(HttpContext context)\n"
" at Microsoft.AspNetCore.Diagnostics.DeveloperExceptionPageMiddlewareImpl.Invoke(HttpContext context)\n"
"2023-12-10 00:55:11.363 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')\n"
"2023-12-10 00:55:11.453 +00:00 [ERR] Error reading log file: Value cannot be null. (Parameter 'path')\n"
"2023-12-10 00:55:30.194 +00:00 [ERR] An unhandled exception has occurred while executing the request.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")