package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Name:\s+(.*)[\s\S]*`)
var str = ` Name: EuroPayment Services S.R.L.
Address: Str. Ion Cămpineanu, nr. 11, Bloc Union, etaj 8, camera 803
Name: General Motors S.R.L.
Address: Str. Ion Cămpineanu, nr. 11, Bloc Union, etaj 8, camera 803`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}