re = /Name:\s+(.*)[\s\S]*/m
str = ' Name: EuroPayment Services S.R.L.
Address: Str. Ion Cămpineanu, nr. 11, Bloc Union, etaj 8, camera 803
Name: General Motors S.R.L.
Address: Str. Ion Cămpineanu, nr. 11, Bloc Union, etaj 8, camera 803'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end