#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?=(?:\s*\d\s*){10}$)(?:0\s*[2378]|1[38])|(?=(?:\s*\d\s*){6}$)1\s*3).*"
Local $sString = "0299998888" & @CRLF & _
"02 99998888" & @CRLF & _
"02 9999 8888" & @CRLF & _
"02 99 998 888" & @CRLF & _
"0299 998 888" & @CRLF & _
"0299 998888" & @CRLF & _
"131999" & @CRLF & _
"131 999" & @CRLF & _
"13 19 99" & @CRLF & _
"1300123456" & @CRLF & _
"1300 123456" & @CRLF & _
"1300 123 456" & @CRLF & _
"1300 12 34 56" & @CRLF & _
"1300 12 34 56" & @CRLF & _
"13145" & @CRLF & _
"1300-123-456" & @CRLF & _
"9999 8888" & @CRLF & _
"(02) 9999 8888"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")