import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?=(?:\\s*\\d\\s*){10}$)(?:0\\s*[2378]|1[38])|(?=(?:\\s*\\d\\s*){6}$)1\\s*3).*";
final String string = "0299998888\n"
+ "02 99998888\n"
+ "02 9999 8888\n"
+ "02 99 998 888\n"
+ "0299 998 888\n"
+ "0299 998888\n"
+ "131999\n"
+ "131 999\n"
+ "13 19 99\n"
+ "1300123456\n"
+ "1300 123456\n"
+ "1300 123 456\n"
+ "1300 12 34 56\n"
+ "1300 12 34 56\n"
+ "13145\n"
+ "1300-123-456\n"
+ "9999 8888\n"
+ "(02) 9999 8888";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}