const regex = /^(?:(?=(?:\s*\d\s*){10}$)(?:0\s*[2378]|1[38])|(?=(?:\s*\d\s*){6}$)1\s*3).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?=(?:\\s*\\d\\s*){10}$)(?:0\\s*[2378]|1[38])|(?=(?:\\s*\\d\\s*){6}$)1\\s*3).*', 'gm')
const str = `0299998888
02 99998888
02 9999 8888
02 99 998 888
0299 998 888
0299 998888
131999
131 999
13 19 99
1300123456
1300 123456
1300 123 456
1300 12 34 56
1300 12 34 56
13145
1300-123-456
9999 8888
(02) 9999 8888`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}