using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<='constant_string' \: )([A-Za-z0-9_])*";
string input = @"'constant_string' : s
'constant_string' : some_string
'constant_string' : some_string
'constant_string' : some_string
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}