$re = '/(?<=\'constant_string\' \: )([A-Za-z0-9_])*/m';
$str = '\'constant_string\' : s
\'constant_string\' : some_string
\'constant_string\' : some_string
\'constant_string\' : some_string
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);