# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w" )/\1\n/gm;t' <<< "Type: \"SecurityIncident\" RowID: \"FB013B06-B04C-4FEB-A5A5-3B858F910F29\""